Chem lab

A haiku,

set up in chem lab
there no power dammit
someone please fix this


@Hayden @Thermoelectric do you know where the breaker/fuse box is?

Is there power in the boneyard and creatorium?

There is a circuit breaker in the creatorium, however last time I checked that didn’t seem to have any problem with it.
Simeon and I checked the power in the creatorium however it also seemed to be off. So it would seem the power points are off in that whole building.
I couldn’t see any power boxes on sight that had any issues and I hear a few other people have done a look around as well. So unfortunately I have no idea how to get the power back on, and I don’t want to be the one too play around with random switches and fuses.

Also, its the science lab :wink:

1 Like

Have a look in the creatroum there’s a RCD mounted under the board on the hat section, it’s more than likely that.

‘science’ would’ve ruined my haiku

I did look at the box on the wall closest to the door behind the kiln but that seemed to be fine, but i’ll look at some point for anything else hiding.


I checked this room when I was at the space yesterday, and there seemed to be power at the wall sockets. So one way or another, it’s working now.

For future reference, either of these two will kill power to the chem lab and possibly the rest of the building (if there are no lights blinking on the chem lab swipe reader check the RCD). The breaker only goes down halfway when tripped so it’s less obvious.


I just inspected the breakers, they look fine, but I can’t get super close to check due to the mound of crud in the way. The RCD has not tripped, and there is still no power to GPO in science lab.

I took a device into the green room and confirmed it worked, then tested in both chem lab and creatorium GPOs and the device will not power up. Retested the device elsewhere and it is fine so i’m confident its not blowing devices up.

So either I have a snooty device or there’s some other issue?

1 Like

Curious. On Saturday I plugged in and turned on the fume cabinet to measure its consumption, and that worked without issues. I was using the GPO nearest the fume cabinet for the supply. Are you sure it’s not your extension cord or power board or something?

Yeah, that seems odd. I also tested the outlet with the fume cabinet on Sunday to confirm it’s that breaker and that worked. Wasn’t aware or any other outlets?

It’s possible since I couldn’t get close that the breaker as you say may have flipped but looks unflipped, I’ll inspect closer tonight.

It’s the GPO nearest the fume cabinet, I also isolated all extension cords and powerboards and found the same issue.

If it is the breaker that keeps flipping, I’m wondering what is continuously flipping it as that means potentially there’s a device that is unsafe (could be the fume hood itself) which needs to be investigated.

Either way, since I’ve checked about 4 different days now, it’s still in a state of borked.

Okay, I had a further look into the problem today. My observations are that there’s an intermittent phase to the creatorium which is causing the weird power problems. I’ve reseated some fuses, and the power is back. Let us know if it drops out again and I’ll poke around some more.