Hacking a POS PinPad

I have one of these wee beasties. My ultimate goal is to get it talking happily with an android tablet, ie taking keyboard input and letting us print things to the screen.

All my officially provided manufacturer documentation I’ve thrown here:

I’ve gotten so far as to plugging it into my laptop, to which the screen says ‘WELCOME !’, but not a lot else happens. I was hoping I could open a serial terminal, but my terminal app doesnt detect it at all.

I’ve asked the manufacturer for a copy of the ‘test software’ but not sure how far I’ll get there.

So, where to go from here? I have no idea where to start pulling apart how this thing works. The datasheet reads to me like you should be able to talk to it over some kind of serial.

My first/current guess at this stage is to grab a rs232 to usb adapter and see if I get any further with that. If so, whats the best adapter for use with macs?

I tried to access the pdfs and my viewer said they were invalid.

you should see if any usb device enumerates when its plugged in to a laptop …eg in windows look in device manager or osx look in the system_profiler command or linux use dmesg or lsusb commands.

If there are windows drivers available… install them and see how they work.,. Perhaps with something like the http://usbsnoop.sourceforge.net/

I’ve had a go running

system_profiler SPUSBDataType

and nothing changes when I plug or unplug the device, I’ve also tried inspecting the usb stack via IORegistryExplorer which gives essentially the same output as far as I can tell.

I’ve resaved those pdfs, perhaps try again?

I’m not sure about windows drivers, waiting on a reply from the manufacturer.

Grab yourself a USB sniffer and try to grab all traffic that goes between the terminal and your computer.
Then see what you find and go from there?

Here is a sniffer for Win:



So I’ve come to the conclusion that its serial comms only, and that the usb port is there for power. Annoying.

Anyhow, I’ve grabbed myself a usb to serial cable and after much swearing at OSX Yosemite for making driver support a huge pain in the ass, managed to get some results.

Print lines: ASCII


Clear Lines: ASCII


as well as various hex codes. These only seem to be documented in the link above, its not really in any of the pdf’s given to me by the retailer.

So, I have to figure out:

  1. How to kick it into a dumb mode where it just sends me every key press and I can respond with what to display etc
  2. If theres a proper usb version of this device
  3. If theres not a proper usb version of this device, how cheaply I can aquire a usb-serial board and solder it to the device to convert the existing usb plug into an adapter (rather than bundle a $15-25 cable with each deployment)

Or even more alternatively, open it up, see what chip is on it, and whether reflashing it is feasible.