Is my motherboard dead?

I can’t seem to work out what the issue is here.

My PC restarts halfway through the Windows or Linux boot process, and Linux live discs restart the PC as soon as I touch the keyboard to choose a boot option. However, the memtest86 option on the HDD’s Grub2 menu boots and runs fine, and doesn’t shut off after several hours of memory testing. This is all with every possible component disconnected (no HDD when booting live).

So I can’t work out what’s wrong, but I’ve narrowed it down to either the CPU or motherboard being at fault since the RAM tests fine and works in other systems. If it’s just the motherboard I can afford to fix it, but if I need a new CPU I’ll be transferring everything to my laptop. So other than buying a new motherboard, how can I discern whether it’s a faulty motherboard or faulty CPU? (I have no other 1155 motherboards/CPUs to test with).

Have you tried re-seating the CPU? I saw that resurrect a machine just yesterday.

Be sure to scrape off the old thermal goop and replace it with fresh stuff.

Have you tried a LiveCD of Stresslinux? It could be something graphical-related (not necessarily your GPU itself, could be the PCIe lines to the GPU on your motherboard). Stresslinux is like memtest86 in that it uses only low-level graphics, unlike eg Inquisitor which briefly uses a higher display setting during its boot loader.

The GPU isn’t on the motherboard, it’s on the die of the Sandy Bridge CPU. If it was an issue like that, then why would YUMI crash when I press the down arrow to choose a boot option?